admin管理员组

文章数量:1612099

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 932 Accepted Submission(s): 488


Problem Description There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
Input The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.
Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.

Sample Input
  
  
   
   2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
  
  

Sample Output
  
  
   
   Case #1: 2.00
Case #2: 5.00


   
   
    
    
     
     Hint
    
    In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

   
   
   
    
  
  

Source 2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)
Recommend liuyiding | We have carefully selected several similar problems for you: 5338 5337 5336 5335 5334


刚开始理解错题了,以为任意两个位置都能直接移动,结果一直超时!!事实上有这句话“two consecutive records.” 在两个连续的时间。。。。。。。。。。。。。
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct nod{
	double tim,opt;
}a[10010];
int cmp(nod a,nod b) {
	return a.tim<b.tim;
}
int main(){
	int t,n,i,j,cas=0;
	scanf("%d",&t);
	while(t--){
		cas++;
		scanf("%d",&n);
		for(i=0;i<n;++i){
			scanf("%lf%lf",&a[i].tim,&a[i].opt);
		}
		sort(a,a+n,cmp);
		double maxn=0,u;	
		for(i=1;i<n;++i){
			maxn = max(maxn,fabs((a[i].opt-a[i-1].opt)/(a[i].tim-a[i-1].tim))) ;
		}
		printf("Case #%d: %.2lf\n",cas,maxn);
	}
	return 0;
}


本文标签: HDOJMattcurious