admin管理员组

文章数量:1612098

There is a curious man called Matt. 

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
Input
The first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records. 

Each of the following N lines contains two integers t  i and x  i (0 ≤ t  i, x  i≤ 10  6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t  i would be distinct.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places. 
Sample Input
2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
Sample Output
Case #1: 2.00
Case #2: 5.00


        
  
Hint
In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>

using namespace std;
struct aa{
    int t,x;
    double v;
}a[10005];
bool cmp(aa a,aa b)
{
    return a.t<b.t;
}
int main()
{
    int n,t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].t,&a[i].x);
        sort(a,a+n,cmp);
        a[0].v=0;double max=0;
        for(int i=1;i<n;i++)
            {a[i].v=fabs((double)(a[i].x-a[i-1].x)/(a[i].t-a[i-1].t));
            if(a[i].v>max)
            max=a[i].v;}
        printf("Case #%d: %.2lf\n",cas,max);

    }
    return 0;
}




本文标签: 函数结构hducuriousCMP