admin管理员组

文章数量:1612099

A Curious Matt

                                                                     Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
                                                                                               Total Submission(s): 1150    Accepted Submission(s): 613


Problem Description There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.  
Input The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.  
Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 
Sample Input
  
  
   
   2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
  
  
 



Sample Output
  
  
   
   Case #1: 2.00
Case #2: 5.00


   
   
    
    
     
     Hint
    
    In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

   
   
   
    
  
  
 

题意:给你N组记录,每组记录输入时刻和位置,让你求这个人可能的最大速度。

分析:原以为是一道物理题,然而并没有那么难,分析一下样例就知道了,我们只需要对每组数据对时间进行排序,然后利用公式,速度=距离/时间,求得最大速度即可,是个平均速度。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <sstream>
#include <fstream>
#define debug "output for debug\n"
#define pi (acos(-1.0))
#define eps (1e-8)
#define inf 0x3f3f3f3f
#define ll long long int
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
const int mod = 1000000007;
const int Max = 100005;
struct node
{
    double x,t;
}a[Max];
bool cmp(node u,node v)
{
    return u.t<v.t;
}
int main()
{
	int T,n,cnt=1;
	cin>>T;
	while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].t,&a[i].x);
        }
        sort(a,a+n,cmp);
        double ans=-1;
        for(int i=1;i<n;i++)
        {
            double tmp=fabs(a[i].x-a[i-1].x)/(a[i].t-a[i-1].t);
            ans=max(tmp,ans);
        }
        printf("Case #%d: ",cnt++);
        printf("%.2lf\n",ans);
    }
    return 0;
}

题目链接: 点击打开链接



Sample Output
   
   
    
    Case #1: 2.00
Case #2: 5.00


    
    
     
     
      
      Hint
     
     In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

    
    
    
     
   
   
 

本文标签: 北京站现场hduMattcurious