admin管理员组

文章数量:1577821

PAT A 1003Emergency (25 分) (C++实现)

问题描述

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1and C2the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c​2and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1 to C​2
​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1and C​2 , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

思路

  1. 就是一个最短路径问题,emmm学过数学建模的应该都不难

代码

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int dis[500],num[500],weight[500],w[500];
    int adj[500][500];
    int visit[500];
    const int inf = 999999;
    int n,m,origin,dest;
    scanf("%d%d%d%d",&n,&m,&origin,&dest);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&weight[i]);
    }
    fill(adj[0],adj[0]+500*500,inf);
    fill(dis,dis+500,inf);
    fill(num,num+500,0);
    int a,b,c;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        adj[a][b] = adj[b][a] = c;
    }
    dis[origin] = 0;
    w[origin] = weight[origin];
    num[origin] = 1;
    for(int i=0;i<n;i++)
    {
        int x=-1, minn=inf;
        for(int j=0;j<n;j++)
        {
            if(!visit[j] && dis[j]<minn) {
                minn = dis[j];
                x = j;
            }
        }
        visit[x] = 1;
        for(int y=0;y<n;y++)
        {
            if(dis[y]>dis[x]+adj[x][y]) {
                dis[y] = dis[x] + adj[x][y];
                num[y] = num[x];
                w[y] = weight[y]+w[x];
            }else if(dis[y] == dis[x]+adj[x][y] && dis[x]!=0) {
                num[y] = num[y] + num[x];
                if(w[x]+weight[y]>w[y]) {
                    w[y] = w[x] + weight[y];
                }
            }
        }

    }
printf("%d %d", num[dest],w[dest]);
    return 0;
}

本文标签: PATEmergency