admin管理员组

文章数量:1577827

题目:

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 

代码:


def Dijkstra(Start, End, L1, L2, Graph):
    global Res1, Res2
    Max = float("inf")
    Distance = [Max] * L1[0]
    Visited = [False] * L1[0]
    Team = [-Max] * L1[0]
    RoadNum = [0]*L1[0]

    Distance[Start] = 0
    Team[Start] = L2[Start]
    RoadNum[Start] = 1

    for i in range(L1[0]):
        Min, Cur = Max, -1
        for j in range(L1[0]):
            if Visited[j] is False and Distance[j] < Min:
                Min = Distance[j]
                Cur = j
        if Cur == -1:
            Res1 = RoadNum[End]
            Res2 = Team[End]
            return
        Visited[Cur] = True
        for k in range(L1[0]):
            if Visited[k] is False and Graph[Cur][k] != Max and\
               Distance[k] >= Distance[Cur] + Graph[Cur][k]:

                if Distance[k] > Distance[Cur] + Graph[Cur][k]:
                    RoadNum[k] = RoadNum[Cur]
                    Team[k] = Team[Cur] + L2[k]
                    Distance[k] = Distance[Cur] + Graph[Cur][k]

                else:
                    if Team[k] < Team[Cur] + L2[k]:
                        Team[k] = Team[Cur] + L2[k]
                    RoadNum[k] = RoadNum[k] + RoadNum[Cur]

    Res1 = RoadNum[End]
    Res2 = Team[End]


def main():
    Max = float("inf")
    Line1 = input()
    Line2 = input()
    Line1 = Line1.split(" ")
    Line1 = list(map(int, Line1))
    Line2 = Line2.split(" ")
    Line2 = list(map(int, Line2))

    Graph = [[Max for j in range(Line1[0])]for i in range(Line1[0])]

    for i in range(Line1[1]):
        LineTemp = input()

        LineTemp = LineTemp.split(" ")
        LineTemp = list(map(int, LineTemp))
        Graph[LineTemp[0]][LineTemp[1]] = LineTemp[2]
        Graph[LineTemp[1]][LineTemp[0]] = LineTemp[2]

    Dijkstra(Line1[2], Line1[3], Line1, Line2, Graph)
    print(Res1, Res2)


main()

    因为也是刚刚学python,自己也感觉的出来代码特别臃肿,也比较复杂,,还望各位提出建议~

本文标签: PythonPATEmergency