admin管理员组

文章数量:1577827

1003 Emergency (25分)

题目

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:
2 4

题意

求无向图中两点的最短路径长度,并记录沿路最大的救援队总和

分析

Dijkstra算法,用priority_queue实现

代码

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int n, m, c1, c2, a, b, c, distTo[510], team[510], maxteam[510], roads[510], marked[510];
vector<pair<int,int> > edge[510];
struct node {
 	int v, d;
 	node(int vv, int dd) :v(vv), d(dd) {}
 	bool operator < (node either) const {
  	return d > either.d;
 	}
};
int main() {
 	fill(distTo, distTo + 510, 99999999);
 	fill(marked, marked + 510, 0);
 	scanf("%d %d %d %d", &n, &m, &c1, &c2);
 	for (int i = 0; i < n; ++i)scanf("%d", &team[i]);
 	for (int i = 0; i < m; ++i) {
  		scanf("%d %d %d", &a, &b, &c);
  		edge[a].push_back(pair<int, int>(b, c));
  		edge[b].push_back(pair<int, int>(a, c));
 	}
 	distTo[c1] = 0;
 	roads[c1] = 1;
 	maxteam[c1] = team[c1];
 	priority_queue<node> q;
 	q.push(node(c1, 0));
 	while (!q.empty()) {
  		int f = q.top().v;
  		if (f == c2)break;
  		if (marked[f])continue;
  		marked[f] = 1;
  		q.pop();
  		for (int i = 0; i < edge[f].size(); ++i) {
   			if (marked[edge[f][i].first])continue;
   			int v = edge[f][i].first, d = edge[f][i].second;
   			if (distTo[v] > distTo[f] + d) {
    				distTo[v] = distTo[f] + d;
    				maxteam[v] = maxteam[f] + team[v];
    				roads[v] = roads[f];
    				q.push(node(v, distTo[v]));
   			}
   			else if (distTo[v] == distTo[f] + d) {
    				roads[v] += roads[f];
    				maxteam[v] = max(maxteam[v], maxteam[f] + d);
   			}
  		}
 	}
 	printf("%d %d", roads[c2], maxteam[c2]);
 	return 0;
}

本文标签: 一个字Emergency