admin管理员组

文章数量:1577825

题目链接:点击打开题目


1003.Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4


套一下地杰斯特拉,注意统计人数和路径条数就行。


代码如下:

#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
typedef long long LL;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define MAXSIZE 500
int ant[MAXSIZE+5];     //当地人数 
int dis[MAXSIZE+5];     //最短距离 
int people[MAXSIZE+5];      //保证最短距离下的最多救人数 
int st,endd;        //起点终点 
int n,m;
int cnt[MAXSIZE+5];     //路径条数 
struct Road
{
    int to;
    int length;
};
struct Ans
{
    int pos;
    int length;
    int people;
    bool friend operator < (Ans a,Ans b)
    {
        if (a.length == b.length)
            return a.people < b.people;
        return a.length > b.length;
    }
};
vector<Road> Edge[MAXSIZE+5];
void init()
{
    for (int i = 0 ; i <= MAXSIZE ; i++)
    {
        dis[i] = INF;
        people[i] = cnt[i] = 0;
    }
}
void dijkstra()
{
    init();
    dis[st] = 0;
    people[st] = ant[st];
    cnt[st] = 1;
    priority_queue<Ans> Q;
    Ans pr,ne;
    pr.pos = st;
    pr.length = 0;
    pr.people = ant[st];
    Q.push(pr);
    bool vis[MAXSIZE+5] = {false};
    while (!Q.empty())
    {
        pr = Q.top();
        Q.pop();
        if (pr.pos == endd)
            break;
        if (vis[pr.pos])
            continue;
        else
            vis[pr.pos] = true;
//      cout << pr.pos << endl;
        for (int i = 0 ; i < Edge[pr.pos].size() ; i++)
        {
            int to = Edge[pr.pos][i].to;
            if (vis[to])
                continue;
            ne.pos = to;
            ne.length = Edge[pr.pos][i].length + pr.length;
            ne.people = ant[to] + pr.people;
            if (ne.length < dis[to])
            {
                dis[to] = ne.length;
                people[to] = ne.people;
                Q.push(ne);
                cnt[to] = cnt[pr.pos];
            }
            else if (ne.length == dis[to])
            {
                if (ne.people > people[to])
                {
                    people[to] = ne.people;
                    Q.push(ne);
                }
                cnt[to] += cnt[pr.pos];
            }
        }
    }
    cout << cnt[endd] << ' ' << people[endd] << endl;
}
int main()
{
    Road p;
    cin >> n >> m >> st >> endd;
    st++;
    endd++;
    for (int i = 1 ; i <= n ; i++)
        cin >> ant[i];
    for (int i = 1 ; i <= m ; i++)
    {
        int x,y,z;
        cin >> x >> y >> z;
        x++;
        y++;
        p.to = y;
        p.length = z;
        Edge[x].push_back(p);
        p.to = x;
        Edge[y].push_back(p);
    }
    dijkstra();
    return 0;
}

/*

5 6 0 2
1 2 1 5 3
0 1 1
0 2 1
0 3 1
1 2 1
2 4 1
3 4 1

6 8 0 5
1 1 1 1 1 1
0 1 1
0 2 1
0 3 1
0 4 1
5 1 1
5 2 1
5 3 1
5 4 1

*/

本文标签: PATEmergency