admin管理员组

文章数量:1648000

HDU-1241-Oil Deposits

Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

这个题就是说以@代表油田,它周边8个方向若有@则表示同一个油田。给你一个图,问你图中有多少个油田。

算是比较简单的DFS题,直接进行搜索, 只是注意对已经搜索过的点进行标记操作。

#include <iostream>
#include <string.h>
using namespace std;
char map[100][100]={};
int n,m;
void dfs(int x,int y)
{
    int a,b;
    int dir[8][2]={1,1, 1,-1, -1,1, -1,-1, 0,1, 0,-1, 1,0, -1,0};
    for(int i=0;i<8;i++)                                  
    {                                                 
     a=x+dir[i][0];                                   
     b=y+dir[i][1];                                   
     if(a<0||b<0||a>=n||b>=m||map[a][b]=='*')    
         continue;          //若该点不可行或越界,跳该点                            
     map[a][b]='*';       //此时该点可行,并把它标记为*,再向8个方向深搜
     dfs(a,b);                                        
    }
}                                                 
int main(int argc, char *argv[])
{
    while(cin>>n>>m)
    {   
        int ans=0;
        if(n==0||m==0)  break;      
        for(int i=0;i<n;i++)           
            scanf("%s",map[i]);       

        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(map[i][j]=='@')
                {
                dfs(i,j);
                ans++;          
                }

        cout<<ans<<endl;    
    }   
    return 0;
}

本文标签: 之路算法专题DFS贴道题吧