admin管理员组

文章数量:1577825

1003 Emergency (25 point(s))

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2 , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

思路:

求最短路径中的路径条数以及点权的最大值,所以先用dijkstra算法,再用w[]和num[]分别记录路径上的点权和,最短路径条数题目中的c1和c2表示的是起点和终点,最后在每次更新d(也就是最短的距离)的时候将num[]和w[]也更新了(如何更新在代码中)。

#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 510;
const int inf = 0x7fffffff;
int g[maxn][maxn], d[maxn], num[maxn], w[maxn], weight[maxn];
bool book[maxn] = {false};
int main() {
	int n, m, start, ed;
	scanf("%d %d %d %d", &n, &m, &start, &ed);
	for (int i = 0; i < n; i++) scanf("%d", &weight[i]);
	fill(g[0], g[0] + maxn * maxn, inf);
	for (int i = 0; i < m; i++) {
		int a, b, c;
		scanf("%d %d %d", &a, &b, &c);
		g[a][b] = g[b][a] = c;
	}
	fill(d, d + maxn, inf);
	d[start] = 0;
	num[start] = 1;
	w[start] = weight[start]; 
	for (int i = 0; i < n; i++) {
		int u = -1, minn = inf;
		for (int j = 0; j < n; j++) {
			if (book[j] == false && d[j] < minn) {
				u = j;
				minn = d[j];
			}
		}
		if (u == -1) break ;
		book[u] = true;
		for (int v = 0; v < n; v++) {
			if (book[v] == false && g[u][v] != inf) {
				if (d[u] + g[u][v] < d[v]) {
					d[v] = d[u] + g[u][v];
					num[v] = num[u];
					w[v] = w[u] + weight[v];
				} else if (d[u] + g[u][v] == d[v]) {
					if (w[v] < w[u] + weight[v]) w[v] = w[u] + weight[v];
					num[v] += num[u];
					
				}
			} 
		}
	}
	cout << num[ed] << " " << w[ed] << endl;
	return 0;
} 

本文标签: PTAEmergencyPoint