admin管理员组

文章数量:1577816

 

1003 Emergency(25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

记得以前做过一次这道题,但是忘得差不多了,好久没碰题目了,感觉生疏的许多,费了好大劲才ac5555555555 

#include<stdio.h>
int mp[505][505]; //模拟地图
int book[505]; //标记数组
int dis[505]; //记录边的数组
int count[505];  //路的数目
int w[505];    //救援队,权值
int city[505];  //初始化的救援队
int n,m,c1,c2;
int inf = 0X3f3f3f3f;
void init()
{
    for(int i = 0;i < n;i++){
        for(int j = 0;j < n;j++){
            if(i == j){
                mp[i][j] = 0;
            }
            else{
                mp[i][j] = inf;
            }
        }
    }
    for(int i = 0;i < n;i++){
        book[i] = 0;
        count[i] = 0;
        w[0] = 0;
    }
}
void dij()
{

    count[c1] = 1;
    w[c1] = city[c1];
    book[c1] = 1;
    for(int i = 0;i < n;i++){
        dis[i] = mp[c1][i];
        if(dis[i] != inf && i != c1){
            w[i] = w[c1] + city[i];
            count[i] = 1;
        }
    }
    for(int i = 0;i < n-1;i++){
        int min = inf;
        int u;
        for(int j = 0;j < n;j++){
            if(book[j] == 0 && dis[j] < min){
                min = dis[j];
                u = j;
            }
        }
        book[u] = 1;
        for(int v = 0;v < n;v++){
            if(mp[u][v] < inf){
                if(!book[v] && dis[v] > dis[u] + mp[u][v]){
                    dis[v] = dis[u]+mp[u][v];
                    w[v] = w[u] + city[v];//更新救援队的数量
                    count[v] = count[u]; //更新到v点的路径数目
                }
                else if(!book[v] && dis[v] == dis[u] + mp[u][v]){
                    count[v] += count[u];
                    if(w[v] < w[u] + city[v]){
                        w[v] = w[u] + city[v];
                    }
                }
            }
        }
    }
}
int main()
{
    scanf("%d %d %d %d",&n,&m,&c1,&c2);
    init();
    for(int i = 0;i  < n;i++){
        scanf("%d",&city[i]);
    }
    for(int i = 0;i < m;i++){
        int u,v,l;
        scanf("%d %d %d",&u,&v,&l);
        mp[u][v] = mp[v][u] = l;
    }
    dij();
    printf("%d %d\n",count[c2],w[c2]);
    return 0;
}

 

本文标签: Emergency