admin管理员组

文章数量:1577824

1003. Emergency (25)

时间限制 400 ms
内存限制 65536 kB
代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
分析:题目求从起始点到终点,最短路有几条,且路径中得到救援队的最大数量

代码:

#include <cstdio>
#include <iostream>
#include <map>
#include <cstring>
#define MAXN 501
#define INF 0x3f3f3f3f
using namespace std;

int n, m, s, t, a, b, c, d[MAXN];
int mat[MAXN][MAXN], amount[MAXN], pcount[MAXN];

void dijkstra()
{
    int dis[MAXN], vis[MAXN]={0};
    memset(dis, 0x3f, sizeof(dis));
    dis[s] = 0;
    amount[s] = d[s];
    pcount[s] = 1;
    while(1)
    {
        int k = -1, minx = INF;
        for(int i = 0; i < n; i++)
        {
            if(!vis[i] && minx > dis[i])
            {
                minx = dis[i];
                k = i;
            }
        }
        if(k == -1) break;
        vis[k] = 1;
        for(int i = 0; i < n; i++)
        {
            if(!vis[i] && dis[i] > dis[k] + mat[k][i])
            {
                dis[i] = dis[k] + mat[k][i];
                amount[i] = amount[k] + d[i];
                pcount[i] = pcount[k];
            }
            else if(!vis[i] && dis[i] == dis[k] + mat[k][i])
            {
                pcount[i] += pcount[k];
                if(amount[i] < amount[k] + d[i])
                    amount[i] = amount[k] + d[i];
            }
        }
    }
}

int main()
{
    memset(mat, 0x3f, sizeof(mat));
    scanf("%d%d%d%d", &n, &m, &s, &t);
    for(int i = 0; i < n; i++)
        scanf("%d", &d[i]);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d%d", &a, &b, &c);
        mat[a][b] = mat[b][a] = c;
    }
    dijkstra();
    printf("%d %d\n", pcount[t], amount[t]);
    return 0;
}



本文标签: 报告LevelAdvancedPATEmergency