admin管理员组

文章数量:1577818

1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 
4
//DFS
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define MIN 100000000
int n,m,start,to;
int map[505][505];
int hand[505];
int book[505];
int minDis=MIN,count,hands;//minDis:最短距离 count:最短距离的路径数目 hands:人手
void DFS(int x,int dis,int sum){
	if(dis>minDis)//剪枝 当路径大于当前最短路径,即刻返回
		return;
	if(x==to){
		if(dis==minDis){//路径依然为当前最短路径
			if(sum>hands)
				hands=sum;
			count++;
			return;
		}
		minDis=dis;//新最短路径
		count=1;
		hands=sum;
		return;
	}
	for(int i=0;i<n;i++){
		if(map[x][i]!=0&&!book[i]){
			book[i]=1;
			DFS(i,dis+map[x][i],sum+hand[i]);
			book[i]=0;
		}
	}
}
int main(){
	int x,y,w;
	cin>>n>>m>>start>>to;
	memset(map,0,sizeof(map));
	memset(book,0,sizeof(book));
	for(int i=0;i<n;i++)
		scanf("%d",&hand[i]);
	for(int i=1;i<=m;i++){
		scanf("%d%d%d",&x,&y,&w);
		map[x][y]=map[y][x]=w;
	}
	book[start]=1;
	DFS(start,0,hand[start]);
	cout<<count<<' '<<hands<<endl;
	return 0;
}


本文标签: PATEmergency