admin管理员组

文章数量:1612098

There is a curious man called Matt. 

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.

Input

The first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records. 

Each of the following N lines contains two integers t i and x i (0 ≤ t i, x i ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t i would be distinct.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places. 

Sample Input

2
3
2 2
1 1
3 4
3
0 3
1 5
2 0

Sample Output

Case #1: 2.00
Case #2: 5.00


        
  

Hint

In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

题意:一个人在跑步,给出其在n个位置的时刻,每两个相邻位置之间这个人速度恒定,忽略加速的时间,问这个人最大速度

数学模型:对xi升序排,更新(x[i]-x[i-1])/(t[i]-t[i-1])的最大值即可 

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
struct st
{
    double x,y;
} a[10001];
int cmp(st q,st p)
{
    return q.x<p.x;
}
int main()
{
    int t;
    scanf("%d",&t);
    int f=0;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%lf%lf",&a[i].x,&a[i].y);
        sort(a,a+n,cmp);
        double ans=0;
        for(int i=1; i<n; i++)
        {
            ans=max(ans,fabs((a[i].y-a[i-1].y)/(a[i].x-a[i-1].x)));

        }
        f++;
        printf("Case #%d: %.2lf\n",f,ans);
    }

    return 0;
}

 

本文标签: 北京站亚洲区MattcuriousICPC