admin管理员组

文章数量:1577829

@pat 题库 1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively.
It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1and C​2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

代码如下:

#include <stdio.h>
#include <string.h>

#define max(a,b) ( ((a)>(b)) ? (a):(b) )
#define min(a,b) ( ((a)>(b)) ? (b):(a) )
int inf = 1000000000;

int n,i,j;
int mark[502]; 
int a[502][502];
int num[502];
int b[502];
int cost[502];
int way[502];

void dijkstra(int s) {
  for ( i = 0; i < n; ++i) {
    cost[i] = inf;  //路上要花费的
    mark[i] = 0;  //标记符号,是否找到最短路径
    num[i] = way[i] = 0;  //返回值,可召集人数,最短路径数目
  }
  num[s] = b[s];  //将该城市拥有的消防员数目先给num
  way[s] = 1;
  cost[s] =  0;
  for ( j = 0; j < n; ++j) {  //五个城市遍历
    int k = -1;
    for ( i = 0; i < n; ++i) {
      if ((!mark[i]) && ((k < 0) || (cost[i] < cost[k]))) {  //将还未找到最短路径的编号最小城市的编号给k
                                                         // 比较他和每一个路径长度,取小的
        k = i;
      }
    } //找出从哪里开始下一轮查找
    mark[k] = 1;     //k城市作为最短路径的一部分
    for ( i = 0; i < n; ++i) {  //五个城市遍历
      if ((!mark[i]) && (a[k][i] < inf)) {
        int temp = cost[k] + a[k][i];        
        if (temp < cost[i]) {
          cost[i] = temp;
          num[i] = num[k] + b[i];
          way[i] = way[k];
        }
        else if (temp == cost[i]) {
          num[i] = max(num[k] + b[i], num[i]);
          way[i] += way[k];
        }
      }
    }
  }
}

int main() {
int m,from,to;
  scanf("%d%d%d%d",&n,&m,&from,&to);    //读取第一行数
  for ( i = 0; i < n; ++i) {
    scanf("%d",b + i);      // 读取第二行数,将每个城市人数存放在数组b中
    for ( j = 0; j < n; ++j) {
      a[i][j] = inf;    //初始将所有两两城市之间的路径长度置为无穷大
    }
  }
  for (;m;--m) {  //读取第三-最后一行数,共计m行
    int x,y,z;
    scanf("%d%d%d",&x,&y,&z);
    a[x][y] = a[y][x] = min(a[x][y],z);   //调整两两城市之间最短路径,直达情况
  }
  dijkstra(from);  //dijkstra算法
  printf("%d %d\n",way[to], num[to]);
  return 0;
}

最大值函数的库我加了<windef.h>,不知道对不对,在codeblock可以用,但是在pat官网上提交显示编译错误,摊手.jpg

用了迪杰斯特拉算法

本文标签: 语言Emergency