admin管理员组

文章数量:1565280

A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project.

InputThe input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single ‘0’.

OutputThe output contains one line. The minimal total cost of the project.

Sample Input3
4 5 6
10 9 11
0
Sample Output
199
这道题就是给你雇佣一个工人需要的钱,工人每月的工资,解雇工人需要的钱,然后问题最少花费是多少

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<iomanip>
#define INF 0x3f3f3f3f
#define E 1e-12
#define N 1000001
#define LL long long
#define MOD 10000
using namespace std;
int dp[20][100000];
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int m[20]={0},salary,fire,hire,maxx=0,ans=INF,k,i,j;
        cin>>hire>>salary>>fire;
        for(i=1;i<=n;i++)
        {
            cin>>m[i];
            maxx=max(maxx,m[i]);
        }
        for(i=1;i<=n;i++)
            for(j=0;j<=maxx;j++)
                dp[i][j]=INF;
        for(i=m[1];i<=maxx;i++)
            dp[1][i]=(hire+salary)*i;
        for(i=2;i<=n;i++)
            for(j=m[i];j<=maxx;j++)
                for(k=m[i-1];k<=maxx;k++)
                {
                    if(k<=j)dp[i][j]=min(dp[i][j],dp[i-1][k]+(j-k)*(hire+salary)+k*salary);
                    else dp[i][j]=min(dp[i][j],dp[i-1][k]+(k-j)*fire+j*salary);
                }
        for(i=m[n];i<=maxx;i++)ans=min(ans,dp[n][i]);
        cout<<ans<<endl;
    }
}

本文标签: DP