admin管理员组

文章数量:1564638

原题:
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable
题意:
有很多组数据,每组数据有以下特点:
有很多由0和1组成的字符串,每一个字符串在此组内都是独一无二的,现在要求你来判断组内是否有某一个字符串为另一个字符串的前缀。(每组之间相互独立)
题解:
又是一个字典树的问题,这个不需要计算数量,只需要判断是否出现过即可。
(更多细节见代码)
附上AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int trie[50001][2],len,tot,root;
char s[50000];
bool flag=0,first=0;
/*
flag用于记录是否有某个字符串为另一个字符串的前缀;
first用于标记是否已经插入第一个(如果不这样可能没有search的对象)
*/
void insert()
{
    len = strlen(s);
    root = 0;
    for(int i=0;i<len;i++)
    {
        int id=s[i]-48;//ascall码值
        if(trie[root][id]==0)trie[root][id]=++tot;//如果不存在,新开一个子节点,指向新的子节点
        //sum[trie[root][id]]++;
        root = trie[root][id];//指向下一个位置
    }
}
bool search()
{
    root = 0;
    len=strlen(s);
    for(int i=0;i<len;i++)
    {
        int id=s[i]-48;
        if(trie[root][id]==0)
        {
            if(trie[root][!id]==0)
                return 1;//包含之前的字符串
            else
                return 0;//不存在
        }
        root=trie[root][id];//指向下一个位置
    }
    return 1;//是之前字符串的前缀
}
int main()
{
    int count=1;
    memset(trie,0,sizeof(trie));
    while(scanf("%s",&s)!=EOF)
    {
        if(s[0]=='9')
        {
            if(flag==0)
                printf("Set %d is immediately decodable\n",count++);
            else
                printf("Set %d is not immediately decodable\n",count++);
            flag=0;
            first=0;
            memset(trie,0,sizeof(trie));
            continue;
        }
        if(flag==0&&first==1)flag=search();
        if(first==0){insert();first=1;}//第一个直接插入,无需判断
        if(flag==0&&first==1)insert();
    }
    return 0;
}

欢迎评论!

本文标签: 字典POJDECODABILITY