admin管理员组

文章数量:1612150

One curious child has a set of N little bricks. From these bricks he builds different staircases. Staircase consists of steps of different sizes in a strictly descending order. It is not allowed for staircase to have steps equal sizes. Every staircase consists of at least two steps and each step contains at least one brick. Picture gives examples of staircase for N=11 and N=5:

Your task is to write a program that reads from input numbers N and writes to output numbers Q - amount of different staircases that can be built from exactly N bricks.

 

Input



Numbers N, one on each line. You can assume N is between 3 and 500, both inclusive. A number 0 indicates the end of input.

 

 

 

Output



Numbers Q, one on each line.

 

 

Sample Input






 

 

 

Sample Output



1
2

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long ll;
ll dp[501][501];//dp[i][j]>>i块砖成j个阶梯 

int main(){
    ll n;
    dp[0][0]=1;
    for(int i=1;i<501;i++){
    	for(int j=i;j>=1;j--){
    		dp[i][j]=dp[i-j][j]+dp[i-j][j-1];//每次去掉最底层的j个砖;
		}
	}
    while(cin>>n&&n){
    	ll sum=0;
    	for(int j=2;j<501;j++){
    		sum+=dp[n][j];
		}
		cout<<sum<<endl;
	}
	return 0;
}

 

本文标签: 背包楼梯