admin管理员组

文章数量:1577538

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 题目翻译:

你是一个救援队长,你要救援有危险的城市,你需要尽可能快的到达有危险的城市,并且带尽可能多的人。

输入:

第1行:4个正整数: 城市数量N、 路数量M、你在的城市、你要救援的城市。

第2行:N个整数,第i个数表示第i个城市的救援队数量。

然后M行:每一行表示一条路,三个数字分别是起点、终点、距离。

保证至少有一条路让你去你要救援的城市。

输出:

最短路径条数  可带的最多人数

 


这道题是一个单源最短路径问题(求节点s到其余各节点的最短路径)。可以使用迪杰斯特拉算法求解:

迪杰斯特拉(Dijkstra)算法:首先求得长度最短的一条最短路径,再求长度次短的一条路径,其余类推,

直到从源点到其他所有点的最短路径都已求得为止。

具体实现参考: https://wwwblogs/caiyishuai/p/9442367.html

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue>

#define inf 0x3f3f3f3f 
using namespace std;
int e[505][505]; //e[i][j] 从i到j的距离
int ti[505]; //ti[i]为 c1到城市i的最短路径条数
int r[505];//r[i]为第i个城市的救援队人数
int rm[505];//rm[i]为c1到城市i的最多救援人数
int v[505];
int d[505];//d[i]为c1到城市i的最短距离
int n, m; //n是城市数量,m是路径数量
int c1, c2;//c1是起点, c2是终点

void dijstra(int s)
{

	for (int i = 1; i <= n; i++) d[i] = e[s][i];
	d[s] = 0;
	v[s] = 1;

	while (1)
	{
		int mm = inf; //记录当前最小的d[i]
		int k = -1;
		for (int i = 1; i <= n; i++)//求第一条最短路径
		{
			if (!v[i] && mm > d[i])  //
			{
				k = i;
				mm = d[i];
			}
		}
		if (k == -1) break;
		v[k] = 1;

		//考虑人数最多
		rm[k] = max(rm[k], r[k] + r[s]);
		//更新d和路径等
		for (int j = 1; j <= n; j++)
		{
			if (d[k] + e[k][j] < d[j]) //c1可以通过k到j
			{
				d[j] = d[k] + e[k][j];
				ti[j] = ti[k];
				rm[j] = rm[k] + r[j];
			}
			else if (d[k] + e[k][j] == d[j])//c1可以通过k到j
			{
				ti[j] += ti[k];
				rm[j] = max(rm[j], rm[k] + r[j]);
			}
		}
	}
}
int main()
{
	while (cin >> n >> m >> c1 >> c2)
	{
		c1++;
		c2++;
		memset(e, inf, sizeof(e));
		memset(ti, 0, sizeof(ti));
		memset(v, 0, sizeof(v));
		memset(rm, 0, sizeof(rm));

		//r[i]为第i个城市的救援队人数
		for (int i = 1; i <= n; i++)
		{
			cin >> r[i];
		}

		for (int i = 1; i <= m; i++)
		{
			int x, y, z;//起点,终点,距离
			cin >> x >> y >> z;
			x++;
			y++;
			if (e[x][y] && x == c1 || y == c1)
			{
				if (x == c1)
					ti[y]++;
				else ti[x]++;
			}

			if (e[x][y] > z) //更新路径
				e[x][y] = e[y][x] = z;
		}
		//简单的初始化
		rm[c1] = r[c1];
		ti[c1] = 1;
		//使用dijstra算法寻找c1最短路径
		dijstra(c1);
		cout << ti[c2] << " " << rm[c2] << endl;
	}
	return 0;
}

 

本文标签: Emergency