admin管理员组

文章数量:1566222


Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4748    Accepted Submission(s): 1943


Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 
Input The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 
Output For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".  
Sample Input
  
  
   
   2

20 3
10 20
3 10
1 7

10 2
1 10
2 11
  
  
 
Sample Output
  
  
   
   Yes
No
  
  
 
Source HDU 2009-10 Programming Contest
#include<iostream>
#include<algorithm>
using namespace std;
struct stu{
	int a,b;
}arr[1010];
bool cmp(stu x,stu y)
{
	return x.b-x.a>y.b-y.a;
	
 } 
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int V,N,f=1;
		cin>>V>>N;
		for(int i=0;i<N;i++)
	    cin>>arr[i].a>>arr[i].b;
	    sort(arr,arr+N,cmp);
	    for(int i=0;i<N;i++)
	    {
	    	if(V>=arr[i].b)
	    	{
	    		V-=arr[i].a;
			}
			else
			{
			f=0;
			break;
		}
		}
		if(f)
		cout<<"Yes"<<endl;
		else
		cout<<"No"<<endl;
	}
 } 

判断 n 件物品是否可以搬进洞里,每件物品有实际体积 v1 和 移动时的额外体积 v2 (V1<=V2);
分析:我们反过来想我把 n 件物品全搬进洞,需要洞的最少体积是多少?
假设有两件物品 a(4,5)、b(6,8)先搬 a 再搬 b 则需的体积是 max(5,4+8)=12 ,反过来就是 max(8,6+5)=11
也就是说假设两件物品时a(x1,y1)、b(x2,y2);答案就是 min (max(y1 , x1+y2) , max(y2 , x2+y1))
 
到这里就很自然的想比较 x1+y2 与 x2+y1 的大小 假设 x1+y2 > x2+y1 则 y2-x2 > y1-x1 ,于是只要先搬 b 就得到 x2+y1,
同样如果 x1+y2 <= x2+y1 则 y2-x2 <= y1-x1 则需先搬 a



本文标签: Crixalisequipment