admin管理员组

文章数量:1582684

A Simple Question of Chemistry
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5647 Accepted: 3757

Description

Your chemistry lab instructor is a very enthusiastic graduate student who clearly has forgotten what their undergraduate Chemistry 101 lab experience was like. Your instructor has come up with the brilliant idea that you will monitor the temperature of your mixture every minute for the entire lab. You will then plot the rate of change for the entire duration of the lab. 

Being a promising computer scientist, you know you can automate part of this procedure, so you are writing a program you can run on your laptop during chemistry labs. (Laptops are only occasionally dissolved by the chemicals used in such labs.) You will write a program that will let you enter in each temperature as you observe it. The program will then calculate the difference between this temperature and the previous one, and print out the difference. Then you can feed this input into a simple graphing program and finish your plot before you leave the chemistry lab. 

Input

The input is a series of temperatures, one per line, ranging from -10 to 200. The temperatures may be specified up to two decimal places. After the final observation, the number 999 will indicate the end of the input data stream. All data sets will have at least two temperature observations. 

Output

Your program should output a series of differences between each temperature and the previous temperature. There is one fewer difference observed than the number of temperature observations (output nothing for the first temperature). Differences are always output to two decimal points, with no leading zeroes (except for the ones place for a number less than 1, such as 0.01) or spaces. After the final output, print a line with "End of Output".

Sample Input

10.0
12.05
30.25
20
999

Sample Output

2.05
18.20
-10.25
End of Output

Source

Mid-Atlantic 2002
给一列数,从第二个数开始,输出其与上一个数字之差,输出取两位小数,输入以“999”数字结束。
找一个变量last存储前一个数,然后读入当前数now,输出其之差,再将当前数now赋值给前一数变量last。
代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int main(void){
    float last = 0, now;

    scanf("%f", &last);
    while (last != 999 && scanf("%f", &now), now != 999){
        printf("%.2f\n", now - last);
        last = now;
    }
    printf("End of Output\n");
    return 0;
}


本文标签: 数列之路之差POJSimple