admin管理员组

文章数量:1565831

Crixalis's Equipment

http://acm.hdu.edu/showproblem.php?pid=3177
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3105    Accepted Submission(s): 1259


Problem Description Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 
Input The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 
Output For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".  
Sample Input
  
  
   
   2

20 3
10 20
3 10
1 7

10 2
1 10
2 11
  
  
 
Sample Output
  
  
   
   Yes
No
  
  
 
Source HDU 2009-10 Programming Contest  
Recommend lcy   |   We have carefully selected several similar problems for you:  1051 1053 1045 1050 1055   /*  先对Ai,Bi进行处理,在进行排序,再按照贪心的思想逐步贪心解决! */ #include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int ai;
int bi;
int c;
}sc[1010];
int cmp(node x,node y)
{
return x.c>y.c;
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
 int i,v,n;
 scanf("%d%d",&v,&n);
 for(i=0;i<n;i++)
 {
  scanf("%d%d",&sc[i].ai,&sc[i].bi);
  sc[i].c=sc[i].bi-sc[i].ai;
 }
  
  
  sort(sc,sc+n,cmp);
  
  int flag=0;
  for(i=0;i<n;i++)
  {
   if(v>=sc[i].bi)//贪心思想的集中体现
  v-=sc[i].ai;
  else
   {
    flag=1;
break;

  }
  if(flag)
    printf("No\n");
    else
      printf("Yes\n");

return 0;
}

本文标签: 贪心ProblemHDOJequipmentCrixalis