admin管理员组

文章数量:1582719

Domination

Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard withN rows andM columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard wasdominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard ofN ×M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input
2
1 3
2 2
Sample Output
3.000000000000

2.666666666667

题意:有个人每天会在一个N*M的棋盘随机的摆放一颗棋子。现在要求摆放成每行、每列至少有一个棋子。问摆放天数的期望。

表示没怎么做过概率DP,做这道题时只推出了4个状态方程,然后就卡壳了o(╯□╰)o

毕竟看的别人题解,感觉写的很好。给个链接:题解点我

看来以后该刷概率DP了。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[2501][51][51];//dp[k][i][j] 表示放k个棋子 占i行 和 j列的概率
int main()
{
    int t;
    int N, M;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &N, &M);
        memset(dp, 0, sizeof(dp));
        dp[0][0][0] = 1;
        double p;
        for(int k = 0; k <= N*M; k++)
        {
            for(int i = 0; i <= N; i++)
            {
                for(int j = 0; j <= M; j++)
                {
                    //k个棋子 占i行 j列 概率为0不考虑
                    //k个棋子占了N行 M列  不再继续放棋子 也不考虑
                    if(i == N && j == M || dp[k][i][j] == 0) continue;
                    //再放一个棋子 满足占i行 j列  
                    //概率为 (i * j - k) / (N * M - k)
                    if(i * j >= k)
                        dp[k+1][i][j] += dp[k][i][j] * (i * j - k) / (N * M - k);
                    //再放一个棋子 满足占i+1行 j列 
                    //概率为 (N - i) * j / (N * M - k)
                    if(i < N)
                        dp[k+1][i+1][j] += dp[k][i][j] * (N - i) * j / (N * M - k);
                    //再放一个棋子 满足占i行 j+1列 
                    //概率为 (M - j) * i / (N * M - k)
                    if(j < M)
                        dp[k+1][i][j+1] += dp[k][i][j] * (M - j) * i / (N * M - k);
                    //再放一个棋子 满足占i+1行 j+1列 
                    //概率为 (N - i) * (M - j) / (N * M - k)
                    if(i < N && j < M)
                        dp[k+1][i+1][j+1] += dp[k][i][j] * (N - i) * (M - j) / (N * M - k);
                }
            }
        }
        double ans = 0;
        for(int i = 0; i <= N*M; i++)//求期望
            ans += i * dp[i][N][M];
        printf("%.12lf\n", ans);
    }
    return 0;
}


本文标签: 概率ZOJDPDomination