UVA 644 Immediate Decodability

编程知识 更新时间:2023-05-02 19:11:02

  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable


题目大意:

如果在一个二进制的字符串集合中如果有一个字符串,是另一个字符串的前缀就不能立即解码。

否则能立即解码。


解析:

水题直接暴力求解。中间用到了一个strstr()函数

strstr() 函数搜索一个字符串在另一个字符串中的第一次出现。
找到所搜索的字符串,则该函数返回字符串的地址;如果未找到所搜索的字符串,则返回NULL。

(strstr(str[i],str[j]) - str[i]) 就能返回第一个字符串,在另一个字符串中所在的位置。


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int N = 1000;
char code[N][N];
bool judge(int n) {
	for(int i = 0; i < n; i++) {
		for(int j = 0; j < n; j++) {
			if(i == j) { // 相等就不需要判断
				continue;
			}
			if( (strstr(code[i],code[j]) - code[i]) == 0) { //如果前一个字符串在后一个字符串中出现过就不能,立即解码
				return false;
			}
		}
	}
	return true;
}
int main() {
	int num = 0;
	int cas = 1;
	while(scanf("%s",code[num]) != EOF) {
		if(code[num][0] == '9') {
			if(judge(num)) {
				printf("Set %d is immediately decodable\n",cas++);
			}
			else {
				printf("Set %d is not immediately decodable\n",cas++);
			}
			num = 0;
		}
		else {
			num++;
		}
	}
	return 0;
}


更多推荐

UVA 644 Immediate Decodability

本文发布于:2023-04-28 05:00:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/f9ff55919efdadd90820fdc07ac77a2e.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:UVA   Decodability

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107768文章数
  • 27244阅读数
  • 0评论数