Jessica's Reading Problem POJ - 3320

编程知识 更新时间:2023-04-03 20:05:01
Jessica's Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17562 Accepted: 6099

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

Source

POJ Monthly--2007.08.05, Jerry   题意:有n页书涵盖所有知识点,求涵盖所有知识点的连续页总数的最小值 思路:尺取法 用set、map、queue进行维护就好了哒~ accode
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<string>
#include<vector>
#include<set>
#include<stack>
#include<queue>
#include<map>
#include<cmath>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
#define MAX_N 1000005
#define gcd(a,b) __gcd(a,b)
#define mem(a,x) memset(a,x,sizeof(a))
#define mid(a,b) a+b/2
#define stol(a) atoi(a.c_str())//string to long
int temp[MAX_N];
int main(){
    //std::ios::sync_with_stdio(false);
    //std::cin.tie(0);
//    #ifndef ONLINE_JUDGE
//        freopen("D:\\in.txt","r",stdin);
//        freopen("D:\\out.txt","w",stdout);
//    #else
//    #endif
    int n;
    queue<int> que;
    set<int> iset;
    map<int,int> imap;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&temp[i]);
        iset.insert(temp[i]);
    }
    int k = iset.size();
    iset.clear();
    int res = inf;
    for(int i = 0; i < n; ++i){
        iset.insert(temp[i]);
        que.push(temp[i]);
        imap[temp[i]]++;
        if(iset.size() == k){
//            printf("%d\n",i);
            res = min(res,(int)que.size());
        }
        while(iset.size() == k){
            int a = que.front();
            imap[a]--;
            que.pop();
            if(imap[a]==0){
                res = min(res,(int)que.size()+1);
                iset.erase(a);
            }

        }

    }
    printf("%d\n",res);
    return 0;
}

 

转载于:https://wwwblogs/zaorunzi/p/9848534.html

更多推荐

Jessica's Reading Problem POJ - 3320

本文发布于:2023-04-03 20:05:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/daa87fba7f45ca3d7d4c7762df61a461.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Reading   Jessica   Problem   POJ

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 39887文章数
  • 14阅读数
  • 0评论数