【hdu】 Immediate Decodability (字典树)

编程知识 更新时间:2023-05-02 19:08:56

Immediate Decodability

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 3
Problem Description An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 
Input Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 
Output For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 
Sample Input
   
   
    
    01
10
0010
0000
9
01
10
010
0000
9

   
   
 
Sample Output
   
   
    
    Set 1 is immediately decodable
Set 2 is not immediately decodable

   
   
 STL: 
1056Accepted680K0MSG++781B2012-08-07 09:51:36

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
    int i,T=0;
    char s[15];
    bool flag;
    while(scanf("%s",s)!=EOF)
    {    int n=0;
         vector<string> v;
         flag=true;
         T++;
         while(s[0]!='9')
         {
            v.push_back(string(s));
            scanf("%s",s);
            n++;
         }
         sort(v.begin(),v.end());
         for(int j=0;j<n-1;j++)
         {
                 if(v[j+1].find(v[j])==0 ){flag=false;break;}
         }
         if(flag==false)  
              printf("Set %d is not immediately decodable\n",T); 
         else printf("Set %d is immediately decodable\n",T);
    }
    return 0;
}
            

静态字典树:
1056Accepted660K0MSG++1230B 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
       int next[2];
       int id;
}head[1000];
char s[15];
bool flag;
int cnt;
void build(char *a,int idx,int id)
{
     int len=strlen(a),i,k;
     for(i=0;i<len;i++)
     {
        k=a[i]-'0';
        if(head[idx].next[k]==0) 
           head[idx].next[k]=cnt++;
        if((head[idx].id)&&(head[idx].id!=id))
           flag=false;
        idx=head[idx].next[k];
     }
     head[idx].id=id;
}
                                
int main()
{
        int i,T=0;;
        while(scanf("%s",s)!=EOF)
        {
                flag=true;
                T++;
                cnt=1;
                memset(head,0,sizeof(head));
                i=1;
                while(s[0]!='9')
                {
                    if(flag) build(s,0,i);
                    scanf("%s",s);
                    i++;
                }
                if(flag==false)
                   printf("Set %d is not immediately decodable\n",T);
                else printf("Set %d is immediately decodable\n",T);
        }
        return 0;
}
                
                
                



更多推荐

【hdu】 Immediate Decodability (字典树)

本文发布于:2023-04-28 04:50:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/c236fe098077dd0e83c020adf619c9d5.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:字典   hdu   Decodability

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107726文章数
  • 27241阅读数
  • 0评论数