POJ 1056 immediately decodable (判断是否有前缀)

编程知识 更新时间:2023-05-02 18:57:37
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

    Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently). 

Output

    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

分析:

这题其实是trie树,但是其特殊性,因为只有0和1的编码,那么我们就可以直接建一个二叉树,0在左子树,1在右子树。然后DFS,判断叶子的个数,因为如果有前缀的编码,那么最后的叶子个数一定小于编码的个数。

过程:

  • 首先声明结点结构体:
struct Node{
    int v;
    Node *left, *right;
    bool known;
    Node():known(false), left(NULL), right(NULL){}
};

  • 建树过程:
void build(Node *root, char *str)
{
    Node *u = root; 
    for(int i=0; i<strlen(str); i++)
    {
        if(str[i]=='0')
        {
            if(u->left==NULL) u->left = newnode();  //遇0向左结点走 
            u = u->left; 
        }else if(str[i]=='1')
        {
            if(u->right==NULL) u->right = newnode();//遇1向右结点走 
            u = u->right;
        }
        u->v = str[i]-'0';//此行可有可无,因为是为了调试建树是否正确才给0或1的值的,如果只是计算叶子的个数,就无需此步。
    }
    return;
}

  • 判断是否为前缀(计算叶子数)
    因为叶子没有左右孩子。用k统计叶子数
void decodable(Node *root, int &k)
{
    Node *u = root;
    if(u->left!=NULL && u->left->known == false)
    {
        u->left->known = true;
        decodable(u->left, k); //DFS
    }
    if(u->right!=NULL && u->right->known == false)
    {
        u->right->known = true;
        decodable(u->right, k);//DFS
    }
    if(u->left == NULL && u->right == NULL) k++;//关键,如果左右孩子没有,则叶子数加一。
}

完整代码:

#include<cstdio>
#include<cstring>
using namespace std;

struct Node{
    int v;
    Node *left, *right;
    bool known;
    Node():known(false), left(NULL), right(NULL){}
};

Node *newnode()
{
    return new Node();
}

void build(Node *root, char *str)
{
    Node *u = root; 
    for(int i=0; i<strlen(str); i++)
    {
        if(str[i]=='0')
        {
            if(u->left==NULL) u->left = newnode();  //遇0向左结点走 
            u = u->left; 
        }else if(str[i]=='1')
        {
            if(u->right==NULL) u->right = newnode();//遇1向右结点走 
            u = u->right;
        }
        u->v = str[i]-'0';
    }
    return;
}

void decodable(Node *root, int &k)
{
    Node *u = root;
    if(u->left!=NULL && u->left->known == false)
    {
        u->left->known = true;
        decodable(u->left, k);
    }
    if(u->right!=NULL && u->right->known == false)
    {
        u->right->known = true;
        decodable(u->right, k);
    }
    if(u->left == NULL && u->right == NULL) k++;
}

int main()
{
    char str[12];
    Node *root = newnode();
    int k = 0;
    int count = 0;
    int kase = 0;
    while(gets(str))
    {
        if(str[0]!='9')
        {
            count++;
            build(root, str);
        }
        if(str[0]=='9'){
            decodable(root, k);
            if(k == count)
            {
                printf("Set %d is immediately decodable\n",++kase);
            }else{
                printf("Set %d is not immediately decodable\n",++kase);
            }
            root = newnode();
            count = k = 0;
        }
    }
    return 0;
} //已AC。

更多推荐

POJ 1056 immediately decodable (判断是否有前缀)

本文发布于:2023-04-28 04:05:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/b00c305d3ec3af82cfb39ee1fb144bd7.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:前缀   判断是否   POJ   decodable   immediately

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107546文章数
  • 27219阅读数
  • 0评论数