抓牛(poj4001)BFS

编程知识 更新时间:2023-05-02 19:07:48

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

解题思路:

  建立队列,通过bfs找寻最优解

code:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct node
{
    int x,c;
}pos[200000];//该点的坐标和走过的步数
int n,k;
queue<node>q;//队列
bool vis[200000];//判断是否走过该点
int bfs()
{
    int p,cnt;
    while(!q.empty())
    {
        p=q.front().x;
        cnt=q.front().c;
        q.pop();
        if(p==k)return cnt;
        if(!vis[p-1]&&p>0)
        {
            vis[p-1]=1;
            pos[p-1].c=cnt+1;
            pos[p-1].x=p-1;
            q.push(pos[p-1]);
        }
        if(p<k)
        {
            if(!vis[p+1])
            {
                vis[p+1]=1;
                pos[p+1].c=cnt+1;
                pos[p+1].x=p+1;
                q.push(pos[p+1]);
            }
            if(!vis[2*p])
            {
                vis[2*p]=1;
                pos[2*p].c=cnt+1;
                pos[2*p].x=2*p;
                q.push(pos[2*p]);
            }
        }
    }
}
int main()
{
    cin>>n>>k;
    memset(vis,0,sizeof(vis));
    memset(pos,0,sizeof(pos));
    vis[n]=1;
    pos[n].x=n;
    pos[n].c=0;
    q.push(pos[n]);
    cout<<bfs()<<endl;
    return 0;
}

更多推荐

抓牛(poj4001)BFS

本文发布于:2023-04-28 04:45:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/9d4f6e9fb99e3fde2f8e43d1cb225384.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:BFS

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107708文章数
  • 27238阅读数
  • 0评论数