Jessica's Reading Problem POJ - 3320 尺取法

编程知识 更新时间:2023-04-03 19:59:02

 

 

Jessica's Reading Problem

 POJ - 3320  

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

题意:求最短区间,使得区间覆盖所有知识点,输出区间长度

map做法:

#include <iostream>
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;

int a[1000007];
map<int, int> mp;
int main() {
	
	int n;
	while (~scanf ("%d", &n)) {
		int all = 0; //所有知识点 
		mp.clear();
		for (int i = 1; i <= n; ++i) {
			scanf ("%d", &a[i]);
			if (!mp[a[i]]++) ++all;
		}
		mp.clear();
		int tail = 1, head = 0, ans = INF;
		int sum = 0; //知识点个数 
		while(1) {
			while (head < n && sum < all) sum += (!mp[a[++head]]++);
			if (sum < all) break;
			ans = min(ans, head - tail + 1);
			sum -= (!--mp[a[tail++]]);
		}
		printf ("%d\n", ans);
	}
	
	return 0;
}

二分离散做法:快很多 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <vector>
using namespace std;
const int INF = 0x3f3f3f3f;

int a[1000007];
int id[1000007];
vector<int> v;
int getid(int x) {
	return lower_bound(v.begin(), v.end(), x) - v.begin() + 1;
}
int main() {
	
	int n;
	while (~scanf ("%d", &n)) {
		v.clear();
		for (int i = 1; i <= n; ++i) {
			scanf ("%d", &a[i]), v.push_back(a[i]);
		}
		sort(v.begin(), v.end()); v.erase(unique(v.begin(), v.end()), v.end());
		int all = v.size();
		memset(id, 0, sizeof(id));
		int tail = 1, head = 0, ans = INF;
		int sum = 0; //知识点个数 
		while(1) {
			while (head < n && sum < all) sum += (!id[getid(a[++head])]++);
			if (sum < all) break;
			ans = min(ans, head - tail + 1);
			sum -= (!--id[getid(a[tail++])]);
		}
		printf ("%d\n", ans);
	}
	
	return 0;
}

 

更多推荐

Jessica's Reading Problem POJ - 3320 尺取法

本文发布于:2023-04-03 19:59:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/91a31be22c10e5d5acafde9ccb7a4bc2.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Reading   Jessica   Problem   POJ

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 39861文章数
  • 14阅读数
  • 0评论数