POJ 题目1056 IMMEDIATE DECODABILITY(字典树)

编程知识 更新时间:2023-05-02 19:06:03
IMMEDIATE DECODABILITY
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11629 Accepted: 5543

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000 

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

Source

Pacific Northwest 1998

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct s
{
	int cnt;
	struct s * child[26];
}node,*Node;
char str[1010][25];
Node root;
void insert(char *str)
{
	int i,now,len;
	Node cur,newnode;
	cur=root;
	len=strlen(str);
	for(i=0;i<len;i++)
	{
		now=str[i]-'0';
		if(cur->child[now]!=NULL)
		{
			cur=cur->child[now];
			cur->cnt++;
		}
		else
		{
			newnode=(Node)calloc(1,sizeof(node));
			cur->child[now]=newnode;
			cur=cur->child[now];
			cur->cnt=1;
		}
	}
}
int seach(char *s)
{
	Node cur;
	cur=root;
	int i,len,now;
	len=strlen(s);
	for(i=0;i<len;i++)
	{
		now=s[i]-'0';
		cur=cur->child[now];
	}
	return cur->cnt;
}
int jud(int k)
{
	int i;
	for(i=0;i<k;i++)
	{
		if(seach(str[i])>1)
			return 0;
	}
	return 1;
}
int main()
{
	int c=0;
	while(scanf("%s",str[0])!=EOF)
	{
		root=(Node)calloc(1,sizeof(node));
		insert(str[0]);
		int k=0;
		while(scanf("%s",str[++k])!=EOF)
		{
			if(str[k][0]=='9')
				break;
			insert(str[k]);
		}
		if(jud(k))
		{
			printf("Set %d is immediately decodable\n",++c);
		}
		else
			printf("Set %d is not immediately decodable\n",++c);
	}
}


更多推荐

POJ 题目1056 IMMEDIATE DECODABILITY(字典树)

本文发布于:2023-04-28 04:38:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/74cca170d022c817b528da872d43da3e.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:字典   题目   POJ   DECODABILITY

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107675文章数
  • 27234阅读数
  • 0评论数