POJ 3278 Catch That Cow 解题报告 [转载]

编程知识 更新时间:2023-05-02 19:09:11

/*
我自己的代码一直WA,但是不知道为什么,所以只好贴别人的了,下一节,HASH+二分搜索~!!!
Catch That Cow
Time Limit: 2000MS  Memory Limit: 65536K 
Total Submissions: 27986  Accepted: 8622 

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

************************************************


*/

#include <iostream>
#include <queue>
#define SIZE 100001
 
using namespace std;
 
queue<int> x;
bool visited[SIZE];
int step[SIZE];
 
int bfs(int n, int k)
{
	int head, next;
	//起始节点入队
	x.push(n);
	//标记n已访问 
	visited[n] = true;
	//起始步数为0 
	step[n] = 0;
	//队列非空时 
	while (!x.empty())
	{
		//取出队头 
		head = x.front();
		//弹出队头 
		x.pop();
		//3个方向搜索 
		for (int i = 0; i < 3; i++)
		{
			if (i == 0) next = head - 1;
			else if (i == 1) next = head + 1;
			else next = head * 2;
			//越界就不考虑了 
			if (next > SIZE || next < 0) continue;
			//判重 
			if (!visited[next])
			{
				//节点入队 
				x.push(next);
				//步数+1 
				step[next] = step[head] + 1;
				//标记节点已访问 
				visited[next] = true;
			}
			//找到退出 
			if (next == k) return step[next];
		}
	}
}
 
int main()
{
	int n, k;
	cin >> n >> k;
	if (n >= k)
	{
		cout << n - k << endl;
	}
	else
	{
		cout << bfs(n, k) << endl;
	}
	return 0;
}






更多推荐

POJ 3278 Catch That Cow 解题报告 [转载]

本文发布于:2023-04-28 04:51:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/64035f0a1eb905bfab143e0b7ae384d0.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:报告   POJ   Cow   Catch

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107731文章数
  • 27241阅读数
  • 0评论数