Jessica‘s Reading Problem POJ - 3320(尺取)

编程知识 更新时间:2023-04-03 19:50:16

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2

题意:
有一本书,书有P页,第 i 页有 一个知识点 ai ,全书中同一个知识点有可能会被在不同的页数中被多次重复提起,所以希望通过阅读其中连续的一些页把所有的知识点全部覆盖到。
给定每一页写到的知识点,请求出要阅读的最少的页数
解:
尺取法,不过要使用map和set容器,详解见注释
容器详解能看懂的看看吧(我是看了好久没看懂)

#include<set>
#include<map>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e6+10;
int a[N];
int p;
void solve()
{
    set<int>all;
    for(int i=0; i<p; i++)//记录知识点,set容器过滤重复的知识点;
    {
        all.insert(a[i]);
    }
    int n=all.size();//知识点的总数;
    int s=0,t=0,num=0;
    map<int,int>count;//知识点映照成知识点出现的次数;
    int res=p;//最大化,即每一页的课本都要看;
    for(;;)
    {
        while(t<p&&num<n)
        {
            if(count[a[t++]]++==0)
            {
                num++;
            }
        }
        if(num<n)
            break;
        res=min(res,t-s);
        if(--count[a[s++]]==0)
            num--;
    }
    printf("%d\n",res);
    return ;
}
 
int main()
{
    while(~scanf("%d",&p))
    {
        for(int i=0; i<p; i++)
            scanf("%d",&a[i]);
        solve();
    }
    return 0;
}

更多推荐

Jessica‘s Reading Problem POJ - 3320(尺取)

本文发布于:2023-04-03 19:50:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/5f9d95bedf897290a115c7f54c14e311.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Reading   Jessica   Problem   POJ

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 39821文章数
  • 14阅读数
  • 0评论数