UVa644_Immediate Decodability(小白书字符串专题)

编程知识 更新时间:2023-05-02 19:08:02

Description


  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable



解题报告

我只能说是艰难的历程,集训一下午才解出一题,WA一次,刚才还不知道出问题在哪呢,结果让小伙伴除了一组数据测试,才知道问题在哪。。。

我的思路是先排序,按长度来排序,然后再比较是否是前缀。。。

#include<stdio.h>
#include<string.h>
int main()
{
    int i,l[10],k,j,t,p,q=0,m=0,n=0;
    char str[8][11],ch[11];
    while(gets(str[0])!=NULL)
    {
        n++;
        i=1;
        l[0]=strlen(str[0]);
        while(gets(str[i])!=NULL)
        {
            if(str[i][0]=='9')
            break;
            l[i]=strlen(str[i]);
            i++;
        }
        for(j=0;j<i;j++)
            for(k=j+1;k<i;k++)
                if(l[j]>l[k])
                {
                    strcpy(ch,str[j]);
                    strcpy(str[j],str[k]);
                    strcpy(str[k],ch);
                    t=l[j];
                    l[j]=l[k];
                    l[k]=t;
                }
        for(j=0;j<i-1;j++)
        {
            q=0;
            for(k=j+1;k<i;k++)
            {
                q=0;
                for(p=0;p<l[j];p++)
                if(str[j][p]==str[k][p])
                    q++;
                if(q==l[j])
                    m++;
            }
        }
        if(m!=0)
        {
            printf("Set %d is not immediately decodable\n",n);
            m=0;
        }
        else printf("Set %d is immediately decodable\n",n);
    }
    return 0;
}


更多推荐

UVa644_Immediate Decodability(小白书字符串专题)

本文发布于:2023-04-28 04:46:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/395e92726a3013cc743a0df39492d7fe.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:字符串   专题   UVa644_Immediate   Decodability   小白书

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107711文章数
  • 27239阅读数
  • 0评论数