寒假训练--字典树--A - Immediate Decodability

编程知识 更新时间:2023-05-02 19:08:40

  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable

这个题就是判断不能有字符串是另一个字符串的前缀,首先将所有字符串存到数组中,在建树时判断有没有重复的,在循环中 if(p->next【k】)  那么证明有一个字符串在这结束了,那个字符串就是正在循环的字符串的前缀,   如果到最后,p->next  不为空,  就证明这个字符串会是其他字符串的前缀


#include <stdio.h>
#include <string.h>
struct node
{
    int flag ;
    node *next[2] ;
};
node *newnode()
{
    node *p = new node ;
    p->flag = 0 ;
    p->next[0] = NULL ;
    p->next[1] = NULL ;
    return p ;
}
int gettree(node *root,char *s)
{
    int i , l = strlen(s);
    node *p = root ;
    for(i = 0 ; i < l ; i++)
    {
        int k = s[i]-'0' ;
        if(p->flag)
        {
            return 0;
        }
        if(p->next[k]==NULL)
            p->next[k] = newnode() ;
        p = p->next[k] ;
    }
    if(p->next[0] == NULL && p->next[1] == NULL && p->flag == 0)
    {
        p->flag = 1 ;
        return 1 ;
    }
    else
        return 0 ;
}
void freedom(node *p)
{
    if(p->next[0]) freedom(p->next[0]);
    if(p->next[1]) freedom(p->next[1]);
    delete p ;
}
int main()
{
    int i , n = 0 , num = 0;
    char s[20][20] ;
    node *head;
    while(scanf("%s", s[n++])!=EOF)
    {
        if(s[n-1][0] != '9') ;
        else
        {
            n-- ; num++;
            head = newnode();
            for(i = 0 ; i < n ; i++)
            {
                int k = gettree(head,s[i]);
                if(k==0) break;
            }
            if(i==n)
                printf("Set %d is immediately decodable\n", num);
            else
                printf("Set %d is not immediately decodable\n", num);
            freedom(head);
            n = 0 ;
        }
    }
}


更多推荐

寒假训练--字典树--A - Immediate Decodability

本文发布于:2023-04-28 04:49:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/3736cd9b8b199cede7e16913617e6e4f.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:字典   寒假   Decodability

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107720文章数
  • 27240阅读数
  • 0评论数