SDUT2117数据结构实验之链表二:逆序建立链表

编程入门 行业动态 更新时间:2024-10-14 18:16:35

SDUT2117数据结构实验之<a href=https://www.elefans.com/category/jswz/34/1769662.html style=链表二:逆序建立链表"/>

SDUT2117数据结构实验之链表二:逆序建立链表

数据结构实验之链表二:逆序建立链表

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Sample Input

10
11 3 5 27 9 12 43 16 84 22 

Sample Output

22 84 16 43 12 9 27 5 3 11 

Hint

不能使用数组!

Source


#include<stdio.h>
#include<stdlib.h>
struct node
{int data;struct node *next;
};
struct node *str(int n)
{int i;struct node *p,*head;head = (struct node *)malloc(sizeof(struct node));head->next=NULL;for(i=1;i<=n;i++){p=(struct node *)malloc(sizeof(struct node));scanf("%d",&p->data);p->next=NULL;p->next=head->next;head->next=p;}return head;
};void print(struct node *head)
{int n=0;struct node *p;p=head->next;while(p!=NULL){if(n==0){printf("%d",p->data);n=1;}elseprintf(" %d",p->data);p=p->next;}
}
int main()
{int n;struct node *h;scanf("%d",&n);h=str(n);print(h);return 0;
}

 

更多推荐

SDUT2117数据结构实验之链表二:逆序建立链表

本文发布于:2024-02-19 13:32:55,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1764023.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:链表   逆序   数据结构

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!