PAT甲级:1055 The World‘s Richest |Python

编程入门 行业动态 更新时间:2024-10-06 14:30:44

<a href=https://www.elefans.com/category/jswz/34/1769282.html style=PAT甲级:1055 The World‘s Richest |Python"/>

PAT甲级:1055 The World‘s Richest |Python

目录

 

题目描述:

Input Specification:

Output Specification:

Sample Input:

Sample Output:

题目大意: 

解题思路: 

Python3代码: 


 

题目描述:

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意: 

输入n个人的信息和k次查询次数,最后每组的输出结果不超过100个人,按照财富从大到小排序,如果财富相同按照年龄从小到大排序,年龄相同再按照姓名字典序从小到大排序。

解题思路: 

首先需要一个Person类 其中包含三个属性:财富、名字、年龄

每次读入一个人的三个属性 就把它定义为一个Person的对象 放入People数组中

再写一个自定义排序的函数来将People这个包含所有Person对象的列表按照题目要求的排序方式进行排序

最后每次都遍历一次People列表 若当前对象的年龄是在范围内 输出即可

因为已经按题目要求排序好了

Python3代码: 

import functools
import sysclass Person :def __init__(self,age,money,name) :self.age = ageself.money = moneyself.name = namedef cmp(a,b) :if a.money != b.money :if a.money > b.money : return -1else : return 1else : if a.age != b.age :if a.age > b.age : return 1else : return -1else :if a.name > b.name : return 1else : return -1n,m = map(int,input().split())
People = []
for _ in range(n) :name,age,money = sys.stdin.readline().split()age = int(age) ; money = int(money)tmp = Person(age,money,name)People.append(tmp)People.sort(key=functools.cmp_to_key(cmp))
#* 先按资产降序排列 再按年龄升序排列 最后按名字升序排列for i in range(1,m+1) :txt = 'Case #{}:'print(txt.format(i))cnt = 0M,amin,amax = map(int,sys.stdin.readline().split())for j in range(n) :if People[j].age >= amin and People[j].age <= amax :print(People[j].name,People[j].age,People[j].money)cnt += 1if cnt == M : breakif cnt == 0 : print('None')

 

 

更多推荐

PAT甲级:1055 The World‘s Richest |Python

本文发布于:2024-02-07 02:46:53,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1752538.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:PAT   World   Python   Richest

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!