HDU 5916 Harmonic Value Description 【构造】(2016中国大学生程序设计竞赛(长春))

编程入门 行业动态 更新时间:2024-10-28 06:32:56

HDU 5916 Harmonic Value Description 【构造】(2016中国大学生程序设计竞赛(<a href=https://www.elefans.com/category/jswz/34/1760540.html style=长春))"/>

HDU 5916 Harmonic Value Description 【构造】(2016中国大学生程序设计竞赛(长春))

Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 3    Accepted Submission(s): 3 Special Judge
Problem Description The harmonic value of the permutation  p1,p2,⋯pn  is
∑i=1n−1gcd(pi.pi+1)
Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
Input The first line contains only one integer T ( 1≤T≤100 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 1≤2k≤n≤10000 ).
Output For each test case, output one line “Case #x:  p1 p2 ⋯ pn ”, where x is the case number (starting from 1) and  p1 p2 ⋯ pn  is the answer.
Sample Input
  2
4 1
4 2

Sample Output
  Case #1: 4 1 3 2
Case #2: 2 4 1 3

Source 2016中国大学生程序设计竞赛(长春)-重现赛
Recommend wange2014   |   We have carefully selected several similar problems for you:   5921  5919  5918  5917  5916 
Statistic |  Submit |  Discuss |  Note


题目链接:

  .php?pid=5916

题目大意:

  给你N和K(1<=K<2K<=2N),求一个1~2N的排列,使得∑gcd(Ai,Ai+1)恰为第K小(等视为相同小)。

题目思路:

  【构造】

  这题一看2K<=2N,可能就是构造题。如果1,2,3...2N排列的话∑gcd(Ai,Ai+1)为第1小。

  若要∑gcd(Ai,Ai+1)=K,只需要将2K和K提出来,将2K放在开头,K放在第二个,接下来只要满足相邻两个数仍然相差1即可。

  只要将K-1~1接在K后面,把K+1~2N接在1后面,去掉2K即可。(2K-1,2K+1为奇数,gcd=1)


//
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-10)
#define J 10000
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define N 104
using namespace std;
typedef long long LL;
double anss;
LL aans,sum;
int cas,cass;
int n,m,lll,ans;
int main()
{#ifndef ONLINE_JUDGEW
//	freopen("1.txt","r",stdin);
//	freopen("2.txt","w",stdout);#endifint i,j,k;
//	init();
//	for(scanf("%d",&cass);cass;cass--)for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
//	while(~scanf("%s",s))
//	while(~scanf("%d",&n)){scanf("%d%d",&n,&m);printf("Case #%d: ",cass);printf("%d %d",m+m,m);for(i=m-1;i;i--)printf(" %d",i);for(i=m+1;i<=n;i++)if(i!=m+m)printf(" %d",i);puts("");}return 0;
}
/*
////
*/



更多推荐

HDU 5916 Harmonic Value Description 【构造】(2016中国大学生程序设计竞赛(长春))

本文发布于:2024-03-06 15:18:23,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1715657.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:长春   程序设计   中国大学生   HDU   Harmonic

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!