【题解】Road Construction POJ

编程入门 行业动态 更新时间:2024-10-09 19:20:38

【<a href=https://www.elefans.com/category/jswz/34/1769599.html style=题解】Road Construction POJ"/>

【题解】Road Construction POJ

Road Construction POJ - 3352

It’s almost summer time, and that means that it’s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Examples

Sample Input
Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3
Sample Output
Output for Sample Input 1
2

Output for Sample Input 2
0

Hint




题意:

给一个无向连通图,至少添加几条边使得去掉图中任意一条边不改变图的连通性(即使得它变为边双连通图)。

题解:

构造边双联通的裸题, 即求出缩点后叶子的数量leaf, 答案即为(leaf+1)/2

经验小结:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const int inf = 1<<30;
const LL maxn = 10010;int N, M, head[maxn], ecnt;
struct node{int to, next;bool inBridge;
}es[maxn];
void addEdge(int u, int v){es[ecnt].to = v;es[ecnt].next = head[u];head[u] = ecnt++;
}
int dfn[maxn], low[maxn], belong[maxn], indx;
bool ins[maxn];
stack<int> st;
int block = 0;
void Tarjan(int u, int pa){bool flag = false;  //判重边int v;ins[u] = true;st.push(u);low[u] = dfn[u] = ++indx;for(int i = head[u]; i != -1; i = es[i].next){v = es[i].to;if(pa==v && !flag){flag = true;continue;}if(!dfn[v]){Tarjan(v, u);low[u] = min(low[u], low[v]);if(low[v] > dfn[u])es[i].inBridge = es[i^1].inBridge = true; //标记正反双向边}else if(ins[v] && pa!=v)low[u] = min(low[u], dfn[v]);}if(low[u] == dfn[u]){++block;do{v = st.top();st.pop();ins[v] = false;belong[v] = block;}while(u != v);}
}
int dg[maxn];   //度数表
int solve(){for(int i = 1; i <= N; ++i)if(!dfn[i])Tarjan(i, -1);for(int i = 1; i <= N; ++i)for(int j = head[i]; j != -1; j = es[j].next){int v = es[j].to;if(es[j].inBridge)     //计算每个块的度, 度为1的即叶子++dg[belong[i]];}int leaf = 0;for(int i = 1; i <= block; ++i)if(dg[i]==1)++leaf; //叶子节点return (leaf+1)/2;
}
void init(){ms(head, -1);
}
int main()
{init();int u, v;cin >> N >> M;for(int i = 1; i <= M; ++i){cin >> u >> v;addEdge(u, v);addEdge(v, u);}cout << solve() << endl;return 0;
}

更多推荐

【题解】Road Construction POJ

本文发布于:2024-03-06 00:57:20,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1713938.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:题解   Road   POJ   Construction

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!