poj——3664——Election Time

编程入门 行业动态 更新时间:2024-10-18 03:33:37

<a href=https://www.elefans.com/category/jswz/34/1766382.html style=poj——3664——Election Time"/>

poj——3664——Election Time

Description

The cows are having their first election after overthrowing the tyrannical Farmer John, and Bessie is one of N cows (1 ≤ N ≤ 50,000) running for President. Before the election actually happens, however, Bessie wants to determine who has the best chance of winning.

The election consists of two rounds. In the first round, the K cows (1 ≤ K ≤ N) cows with the most votes advance to the second round. In the second round, the cow with the most votes becomes President.

Given that cow i expects to get Ai votes (1 ≤ Ai ≤ 1,000,000,000) in the first round and Bi votes (1 ≤ Bi ≤ 1,000,000,000) in the second round (if he or she makes it), determine which cow is expected to win the election. Happily for you, no vote count appears twice in the Ai list; likewise, no vote count appears twice in the Bi list.

Input

* Line 1: Two space-separated integers: N and K 
* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

Output

* Line 1: The index of the cow that is expected to win the election.

Sample Input

5 3
3 10
9 2
5 6
8 4
6 5

Sample Output

5

#include<iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,k;
const int M=50010;
struct node
{int a;int b;int num;
}Node[M];
int cmpa(node a,node b)
{if(a.a!=b.a)return a.a>b.a;elsereturn a.b>b.b;
}
int cmpb(node a,node b)
{if(a.b!=b.b)return a.b>b.b;elsereturn a.a>b.a;
}
int main()
{while(cin>>n>>k){for(int i=0;i<n;i++){scanf("%d%d", &Node[i].a, &Node[i].b);Node[i].num=i+1;}sort(Node,Node+n,cmpa);sort(Node,Node+k,cmpb);printf("%d\n",Node[0].num);}return 0;
} 


更多推荐

poj——3664——Election Time

本文发布于:2024-02-27 18:00:17,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1707664.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:poj   Time   Election

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!