HDU 1686:Oulipo ← KMP算法

编程入门 行业动态 更新时间:2024-10-17 19:34:14

HDU 1686:Oulipo ← KMP<a href=https://www.elefans.com/category/jswz/34/1770096.html style=算法"/>

HDU 1686:Oulipo ← KMP算法

【题目来源】
.php?pid=1686
=3461

【题目描述】
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

【输入格式】
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

【输出格式】
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

【输入样例】
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

【输出样例】
1
3
0

【算法分析】
1.常规定义的 KMP 函数,第一个参数为主串,第二个参数为模式串,但是本题中给出的样例是先输入模式串,再输入主串。故在本题中调用定义的 KMP 函数时,要注意参数顺序。
2.本题中统计的是模式串在主串中重复出现的次数,故在 KMP 函数中,把在 if(j==lent) 时,不重复进行统计时的 j=0 修改为重复进行统计时的 j=ne[j]。
3.实证知在 HDU 中不支持对 string 求长度,故可将如下代码中的 string 修改为字符数组后再提交至 HDU 进行测试。但是要注意,字符数组 x 的长度用 strlen(x) 进行计算,字符串 x 的长度用 x.length() 进行计算。

【算法代码:string版本】
本 string 版本代码是正确的,但是在 HDU 上不能通过测试,原因是 HDU 无法识别 string。

#include<bits/stdc++.h>
using namespace std;const int maxn=1e4+5;
int ne[maxn];void getNext(string t) {int len=t.length();int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(string S,string T) {int lens=S.length();int lent=T.length();int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {string s,t;cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/


【算法代码:字符数组版本】
本字符数组版本代码,在 HDU 上可正常通过测试。此字符数组版本代码,只是在 string 版本代码基础上做了微改。

#include <iostream>
#include <cstring>
using namespace std;const int maxn=1e6+5;
char s[maxn];
char t[maxn];
int ne[maxn];void getNext(char t[]) {int len=strlen(t);int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(char S[],char T[]) {int lens=strlen(S);int lent=strlen(T);int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/




【参考文献】






 

更多推荐

HDU 1686:Oulipo ← KMP算法

本文发布于:2023-11-16 10:10:49,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1617641.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:算法   HDU   KMP   Oulipo

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!