HDU 1241 Oil Deposits

编程入门 行业动态 更新时间:2024-10-11 23:20:31

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

 

1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

 

 

Sample Output

 

0 1 2 2

题意:找油田的数量!

思路:用DFS去一个一个地覆盖油田

AC代码:

#include<stdio.h>
#include<string.h>
#define N 105
char str[N][N];
int dir[8][2]={1,0, -1,0, 0,1 , 0,-1, 1,1, 1,-1, -1,1, -1,-1};  //8个方向
int n,m,ans;
void dfs(int a,int b)
{
    str[a][b]='*';              //覆盖
    for(int i=0;i<8;i++)
    {
        int x=a+dir[i][0];
        int y=b+dir[i][1];
        if(x>=0&&y>=0&&x<n&&y<m&&str[x][y]=='@')
            dfs(x,y);
    }
}
int main()
{
    int i,j;
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        ans=0;
        for(i=0;i<n;i++){
                scanf("%s",str[i]);
        }
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                if(str[i][j]=='@')
                {
                    ans+=1;
                    dfs(i,j);
                }
            }
        }

        printf("%d\n",ans);
    }
    return 0;
}

 

更多推荐

HDU 1241 Oil Deposits

本文发布于:2023-06-14 04:32:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1437938.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:HDU   Deposits   Oil

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!