HDU2126:Buy the souvenirs(01)

编程入门 行业动态 更新时间:2024-10-26 22:26:04
Problem Description When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will Buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 
Input For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.  
Output If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”  
Sample Input
  
  
   
   2
4 7
1 2 3 4

4 0
1 2 3 4
  
  
 
Sample Output
  
  
   
   You have 2 selection(s) to buy with 3 kind(s) of souvenirs.
Sorry, you can't buy anything.
  
  
  
  

  
  
  
  
   
   
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,sum,a[35];
int dp[505][2];

int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&sum);
        for(i = 0; i<n; i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(i = 0; i<=sum; i++)
            dp[i][1]=1;
        for(i = 0; i<n; i++)
        {
            for(j = sum; j>=a[i]; j--)
            {
                if(dp[j][0]==dp[j-a[i]][0]+1)
                    dp[j][1]=dp[j-a[i]][1]+dp[j][1];
                else if(dp[j][0]<dp[j-a[i]][0]+1)
                {
                    dp[j][0]=dp[j-a[i]][0]+1;
                    dp[j][1]=dp[j-a[i]][1];
                }
            }
        }
        if(dp[sum][0])
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",dp[sum][1],dp[sum][0]);
        else
            printf("Sorry, you can't buy anything.\n");
    }

    return 0;
}


更多推荐

HDU2126:Buy the souvenirs(01)

本文发布于:2023-06-14 03:55:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1436038.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Buy   souvenirs

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!