PAT (Advanced Level) Practise 1003 Emergency

编程入门 行业动态 更新时间:2024-10-28 18:26:13

1003. Emergency (25)

时间限制 400 ms
内存限制 65536 kB
代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

题意:有n个城市,m条边,各边都有权值而且个点也有权值,求出给定两点之间最短路的条数并输出此路径上的点权值和的最大值。

解题思路:最短路


#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

struct node
{
    int id,dis;
    friend bool operator<(node x,node y)
    {
        return x.dis>y.dis;
    }
} pre,nt1;
int n,m,ss,ee;
int a[600],pathnum[600],dis[600],visit[600],sum[600];
int s[600],nt[1000000],e[1000000],l[1000000];

void Dijkstra()
{
    priority_queue<node>q;
    pre.id=ss,pre.dis=0;
    pathnum[ss]=1,sum[ss]=a[ss];
    memset(visit,0,sizeof visit);
    memset(dis,INF,sizeof dis);
    dis[ss]=0;
    q.push(pre);
    while(!q.empty())
    {
        pre=q.top();
        q.pop();
        visit[pre.id]=1;
        if(pre.id==ee) break;
        for(int i=s[pre.id]; ~i; i=nt[i])
        {
            int k=e[i];
            if(visit[k]) continue;
            if(dis[k]>dis[pre.id]+l[i])
            {
                dis[k]=dis[pre.id]+l[i];
                sum[k]=sum[pre.id]+a[k];
                pathnum[k]=pathnum[pre.id];
                nt1.id=k;
                nt1.dis=dis[k];
                q.push(nt1);
            }
            else if(dis[k]==dis[pre.id]+l[i])
            {
                pathnum[k]+=pathnum[pre.id];
                if(sum[k]<sum[pre.id]+a[k])
                    sum[k]=sum[pre.id]+a[k];
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d %d %d",&n,&m,&ss,&ee))
    {
        int cnt=1;
        for(int i=0; i<n; i++) scanf("%d",&a[i]);
        memset(s,-1,sizeof s);
        memset(nt,-1,sizeof nt);
        int f,t,ll;
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d %d",&f,&t,&ll);
            nt[cnt]=s[f],s[f]=cnt,e[cnt]=t,l[cnt++]=ll;
            nt[cnt]=s[t],s[t]=cnt,e[cnt]=f,l[cnt++]=ll;
        }
        Dijkstra();
        printf("%d %d\n",pathnum[ee],sum[ee]);
    }
    return 0;
}

更多推荐

PAT (Advanced Level) Practise 1003 Emergency

本文发布于:2023-06-11 00:32:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1361253.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Level   Advanced   PAT   Emergency   Practise

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!