poj 2299 Ultra-QuickSort——归并排序

编程入门 行业动态 更新时间:2024-10-26 08:28:53

Ultra-QuickSort

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题意: 给定一个序列,问经过多少次相邻元素的交换可以达到升序的状态。

题解: 利用归并排序来计算排列次数。

c++ AC 代码

#include<cstdio>
#include<cstdlib>
#include<iostream>
using namespace std;
const int maxn = 500010;
int a[maxn], b[maxn];
long long sum;

void merge_i(int *a, int low, int mid, int high)
{
	int i, j, k;
	i = low, j = mid + 1, k = low;
	while(i <= mid && j <= high)
	{
		if(a[i] > a[j])
		{
			sum += j - k;
			b[k++] = a[j++];
		}
		else
			b[k++] = a[i++];
	}
	while(i <= mid)
		b[k++] = a[i++];
	while(j <= high)
		b[k++] = a[j++];
	for(int i=low;i<=high;i++)
		a[i] = b[i];
}

void merge_sort(int *a,int low, int high)
{
	if(low < high)
	{
		int mid = (low+high) / 2;
		merge_sort(a,low,mid);
		merge_sort(a,mid+1,high);
		merge_i(a,low,mid,high);
	}
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF && n)
	{
		sum = 0;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		merge_sort(a,1,n);
		printf("%lld\n",sum);
	}
	return 0;
}

归并排序:O(∩_∩)O

更多推荐

poj 2299 Ultra-QuickSort——归并排序

本文发布于:2023-06-13 07:33:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1357754.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:poj   QuickSort   Ultra

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!