HDU2717:Catch That Cow(BFS)

编程入门 行业动态 更新时间:2024-10-09 03:24:14

HDU2717:<a href=https://www.elefans.com/category/jswz/34/1771042.html style=Catch That Cow(BFS)"/>

HDU2717:Catch That Cow(BFS)

Problem Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?  
Input Line 1: Two space-separated integers: N and K  
Output Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.  
Sample Input
  
  
   
   5 17
  
  
 
Sample Output
  
  
   
   4


   
   
    
    
     
     Hint
    
    The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
   
   
   
    
  
  


 

对所有状况进行一次搜索,最先找到的肯定就是时间最少的。

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

const int N = 1000000;
int map[N+10];
int n,k;
struct node
{
    int x,step;
};

int check(int x)
{
    if(x<0 || x>=N || map[x])
        return 0;
    return 1;
}

int bfs(int x)
{
    int i;
    queue<node> Q;
    node a,next;
    a.x = x;
    a.step = 0;
    map[x] = 1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        if(a.x == k)
            return a.step;
        next = a;
        //每次都将三种状况加入队列之中
        next.x = a.x+1;
        if(check(next.x))
        {
            next.step = a.step+1;
            map[next.x] = 1;
            Q.push(next);
        }
        next.x = a.x-1;
        if(check(next.x))
        {
            next.step = a.step+1;
            map[next.x] = 1;
            Q.push(next);
        }
        next.x = a.x*2;
        if(check(next.x))
        {
            next.step = a.step+1;
            map[next.x] = 1;
            Q.push(next);
        }
    }
    return -1;
}

int main()
{
    int ans;
    while(~scanf("%d%d",&n,&k))
    {
        memset(map,0,sizeof(map));
        ans = bfs(n);
        printf("%d\n",ans);
    }
    return 0;
}


 

更多推荐

HDU2717:Catch That Cow(BFS)

本文发布于:2023-08-03 05:27:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/34/1284862.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Catch   BFS   Cow

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!