POJ 1056 IMMEDIATE DECODABILITY(字典树 水题)

编程知识 更新时间:2023-05-02 19:06:23
IMMEDIATE DECODABILITY
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13014 Accepted: 6235

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

【题意】要求所给字符串是否有的是其他字符串的前缀。

【解题方法】可以想到字典树,字典树的一个分支记录一个字符串,叶子节点做相应的标记。如果在字典树上插入新字符串的时候经过先前的叶子节点标记,则说明以该节点为叶子节点的路径上的字符串是当前插入字符串的前缀;如果在字典树上插入新字符串的长度小于当前所在的分支,则说明当前插入字符串是经过当前路径的所有分支所标示的字符串的前缀。

【AC 代码】

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100010;
char s[20];
bool ff;
struct Trie{
	int root,sz,nxt[maxn][2],flag[maxn];
	int newnode()
	{
	    flag[sz]=0;
	    nxt[sz][0]=nxt[sz][1]=-1;
	    return sz++;
	}
	void init()
	{
	    sz=0;
	    root=newnode();
	}
	void insert(char *s)
	{
	    int u=root,n=strlen(s);
	    for(int i=0; i<n; i++){
            int &v=nxt[u][s[i]-'0'];
            if(v!=-1)
            {
                if(flag[v]||i==n-1)
                {
                    ff=false;
                    return ;
                }
            }
            else{
                v=newnode();
            }
            u=v;
	    }
	    flag[u]=1;
	}
}trie;

int main()
{
	int cas=1;
	while(scanf("%s",s)!=EOF)
	{
		ff=true;
		trie.init();
		trie.insert(s);
		while(scanf("%s",s))
		{
			if(strcmp(s,"9")==0) break;
			if(ff) trie.insert(s);
		}
		if(!ff) printf("Set %d is not immediately decodable\n",cas++);
		else printf("Set %d is immediately decodable\n",cas++);
	}
	return 0;
}


更多推荐

POJ 1056 IMMEDIATE DECODABILITY(字典树 水题)

本文发布于:2023-04-28 04:40:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/1bd83f377bc3f63797dd0ff34ae54f98.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:字典   POJ   水题   DECODABILITY

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 107682文章数
  • 27235阅读数
  • 0评论数