Jessica's Reading Problem POJ - 3320(尺取法)

编程知识 更新时间:2023-04-03 20:02:35

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2
昨天codeforces C题是考察尺取法的,但是这一块不大熟悉,搞点题练练。
思路:这算是一个比较基础的尺取法的题目了。尺取法就是两个指针,来回搞。比起双重循环快了很多很多。我们首先移动右指针,直到数量达到所有知识点的数量。然后移动左指针,不断地更新最小值,直到知识点的数量少于所有的知识点的数量。
代码如下:

#include<iostream>
#include<cstdio>
#include<map> 
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=1e6+100;
int a[maxx];
int n;

int main()
{
	scanf("%d",&n);
	map<int,int> mp;
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		if(mp[a[i]]==0) mp[a[i]]=1,cnt++;
	}
	int l=1,r=1;
	mp.clear();
	int sum=0;
	int _max=inf;
	while(r<n)
	{
		while(sum<cnt&&r<=n) 
		{
			if(mp[a[r]]==0) sum++;
			mp[a[r]]++;
			r++;
		}
		r--;
		while(sum==cnt)
		{
			_max=min(_max,r-l+1);
			mp[a[l]]--;
			if(mp[a[l]]==0) sum--;
			l++;
		}
		r++;
	}
	printf("%d\n",_max);
	return 0;
}

努力加油a啊,(o)/~

更多推荐

Jessica's Reading Problem POJ - 3320(尺取法)

本文发布于:2023-04-03 20:02:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/1696e5951d8c13b4f51d803cdebbafef.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:Reading   Jessica   Problem   POJ

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 39877文章数
  • 14阅读数
  • 0评论数