算法入门 21.Jessica‘s Reading Problem(尺取法)

编程知识 更新时间:2023-04-03 20:03:57

Jessica's Reading Problem

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 27011Accepted: 8877

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2
#include<iostream>
#include<set>
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
#include<cstdlib>
using namespace std;
int p;
const int maxn=10010;
int a[10010];
void init(){
    cin>>p;
    for(int i=0;i<p;i++) cin>>a[i];
}
void solve(){
    set<int> all;
    for(int i=0;i<p;i++){
        all.insert(a[i]);
    }
    int n=all.size();
    map<int,int>count;
    int s=0;
    int t=0;
    int num=0;
    int res=p;
    for(;;){
        while(t<p&&num<n){
            if(count[a[t++]]==0){
                num++;
            }
        }
        if(num<n) break;
        res=min(res,t-s);
        if(--count[a[s++]]==0){
            num--;
        }
    }
    cout<<res;
}
int main(){
    init();
    solve();
}

更多推荐

算法入门 21.Jessica‘s Reading Problem(尺取法)

本文发布于:2023-04-03 20:03:00,感谢您对本站的认可!
本文链接:https://www.elefans.com/category/jswz/004e165d7ebc16263faae2b1e2c70847.html
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系,我们将在24小时内删除。
本文标签:算法   入门   Problem   Reading   Jessica

发布评论

评论列表 (有 0 条评论)
草根站长

>www.elefans.com

编程频道|电子爱好者 - 技术资讯及电子产品介绍!

  • 39883文章数
  • 14阅读数
  • 0评论数